The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.
This issue has been resolved. If further assistance is needed please reach out to Brightly Support: support@brightlysoftware.com
Posted Oct 21, 2025 - 08:15 EDT
Update
Due to ongoing outages with Amazon Web Services (AWS), clients may experience slowness within Asset Essentials. Our teams are actively working with our cloud partner to resolve the issue as quickly as possible. During this time please refrain from doing mass updates, exports, or imports in Asset Essentials. We appreciate your patience and will provide updates as they become available.
Posted Oct 20, 2025 - 13:20 EDT
Update
Due to ongoing outages with Amazon Web Services (AWS), clients may experience slowness within Asset Essentials. Our teams are actively working with our cloud partner to resolve the issue as quickly as possible. We appreciate your patience and will provide updates as they become available.
Posted Oct 20, 2025 - 08:28 EDT
Investigating
Our team is currently investigating a latency issue with Asset Essentials. This is being investigated as our top priority and we will work to have a resolution out as soon as possible. Thank you for your patience! Please contact assetessentialshelp@brightlysoftware.com if you have any questions.
Posted Oct 20, 2025 - 08:12 EDT
This incident affected: Work and Asset Management (Asset Essentials).