Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Mobile311 - App Store Issue
Incident Report for Brightly Software
Resolved
This incident has been resolved.
Posted May 15, 2023 - 10:54 EDT
Investigating
Our team is currently investigating an issue that is preventing the Mobile311 Pro app from appearing in the Android and iOS app stores. This is a top priority and we will continue to provide updates on this page. Thank you for your patience!
Posted Mar 30, 2023 - 12:03 EDT
This incident affected: Work and Asset Management (Mobile311).