Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Asset Essentials Login
Incident Report for Brightly Software
Resolved
This incident has been resolved. We will continue to monitor performance.
Posted Jan 06, 2023 - 12:24 EST
Investigating
Our team is currently investigating an issue impacting access to Asset Essentials. This is a top priority for our team and we hope to have a resolution soon. We apologize for the inconvenience and will continue to post updates on this page.
Posted Jan 06, 2023 - 10:55 EST
This incident affected: Work and Asset Management (Asset Essentials).