Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Asset Essentials- PowerBI reporting issue

Incident Report for Brightly Software

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 13:18 EDT

Update

We are continuing to investigate an issue with PowerBI reports not being able to be saved and scheduled.
Posted Oct 07, 2025 - 08:49 EDT

Update

We are investigating an issue with PowerBI reports not being able to be saved and scheduled. Teams are actively investigating and working to resolve this as soon as possible.
Posted Sep 23, 2025 - 10:06 EDT

Investigating

We’ve identified an issue affecting PowerBI reports in Asset Essentials, where some reports are failing to load or display data. Teams are actively investigating and working to resolve this as soon as possible.
Posted Sep 19, 2025 - 17:09 EDT
This incident affected: Work and Asset Management (Asset Essentials).