Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Support service disruption

Incident Report for Brightly Software

Resolved

This issue has been resolved and support channels are operational. Thank you for your patience. Please contact support@brightlysoftware.com if you have any questions.
Posted Jun 26, 2026 - 20:51 EDT

Investigating

We are currently experiencing a service disruption due to an outage with our CRM provider. As a result, you may be unable to reach our Brightly Support team through our normal channels. Our team is actively monitoring the situation and will update you as soon as service has been restored.

Thank you for your patience, and we apologize for the inconvenience. Please email support@brightlysoftware.com, and a member of our team will respond to you as quickly as possible.
Posted Jun 26, 2026 - 17:16 EDT
This incident affected: Work and Asset Management (Asset Essentials).