The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2024 - 20:00 EDT
Scheduled
Brightly will have a critical maintenance window on Thursday, March 21st from 8:00 PM EST to 9:00 PM EST. During this time, some services, including Asset Essentials email and Analytics, may be intermittently unavailable. Please subscribe to our status page at status.brightlysoftware.com for real-time information during this maintenance window, as well as any future status updates from Brightly. If you have any questions, please contact our Legendary Support team at support@brightlysoftware.com.
Posted Mar 21, 2024 - 18:07 EDT
This scheduled maintenance affected: Work and Asset Management (Asset Essentials, CapitalForecastDirect, Capital Forecast, Asset Essentials Analytics) and Event Management (Event Manager).