Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Event Manager - Billing & Contact Information Issue

Incident Report for Brightly Software

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 08:26 EDT

Identified

We have identified an issue with the Contact and Billing information in Event Manager. Until this issue is resolved, we recommend avoiding edits to existing events unless absolutely necessary. This will help prevent incorrect information from being populated on events.

If you do edit an existing event, please check the Contact and Billing information on the invoice and/or public calendar, and ensure the event you are editing in Event Manager is showing accurate information before saving the event.
Posted Oct 03, 2025 - 13:59 EDT
This incident affected: Event Management (Event Manager).