Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Brightly Support - Emails not being received by support team
Incident Report for Brightly Software
Resolved
The issue regarding client emails not being received by the support team has been resolved. We are now receiving emails sent to assetessentialshelp@brightlysoftware.com, events.support@brightlysoftware.com, and stream.support@brightlysoftware.com. Thank you for your patience as we worked to resolve this issue.
Posted Dec 19, 2023 - 13:58 EST
Investigating
We are currently investigating an issue regarding emails not being received by the support team. The impacted email addresses are assetessentialshelp@brightlysoftware.com, events.support@brightlysoftware.com, and stream.support@brightlysoftware.com. If you need to email support for these products, please email support@brightlysoftware.com or call 877-655-3833. We will continue to post updates on this page and appreciate your patience while we resolve this issue.
Posted Dec 18, 2023 - 19:32 EST
This incident affected: Work and Asset Management (Asset Essentials), Event Management (Event Manager), and Energy Management (Stream).