Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

HelpDesk MSB Login Issue
Incident Report for Brightly Software
Resolved
This incident has been resolved.
Posted Nov 08, 2023 - 10:53 EST
Update
This incident is now resolved. Thank you for your patience!
Posted Nov 08, 2023 - 10:53 EST
Update
We continue to investigate this issue as our highest priority. We apologize for the inconvenience and will continue to provide updates on this page. Thank you for your patience!
Posted Nov 07, 2023 - 09:19 EST
Investigating
Our team is currently investigating an issue which is preventing users from logging into HelpDesk via MySchoolBuilding. At this time, please login to HelpDesk using https://login.schooldude.com. We apologize for the inconvenience and will continue to provide updates on this page. Thank you for your patience!
Posted Nov 06, 2023 - 16:36 EST
This incident affected: IT Asset Management (Help Desk).