The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.
Our team is still working to identify the root cause of the issue impacting the ability to view and enter bill data in Energy Manager when working in Google Chrome. Until this issue is resolved, please continue leveraging the workaround of utilizing a Firefox or Edge web browser. Thank you for your patience while we work to resolve this issue.
Posted Mar 31, 2025 - 08:48 EDT
Investigating
Our team is investigating an intermittent issue resulting in a blank screen upon viewing and entering utility bill data in Energy Manager. This issue is impacting users working in Google Chrome and is being investigated as a top priority. Until a resolution has been identified, the workaround is to access Energy Manager using a Firefox or Edge browser. Please contact energysupport@brightlysoftware.com with any questions.
Posted Mar 27, 2025 - 09:48 EDT
This incident affects: Energy Management (Energy Manager).