Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Asset Essentials - Dashboard redirect issue

Incident Report for Brightly Software

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2026 - 16:27 EDT

Investigating

Our team is currently investigating an issue causing an incorrect redirect to the Dashboard page within Asset Essentials when clicking on various areas within the application. This is being investigated as our top priority and we will work to have a resolution out as soon as possible. Thank you for your patience! Please contact assetessentialshelp@brightlysoftware.com if you have any questions.
Posted Jun 19, 2026 - 11:34 EDT
This incident affects: Work and Asset Management (Asset Essentials).