Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

MaintenanceDirect: Issue with Work Order Counts on Home Page

Incident Report for Brightly Software

Identified

Our team has identified the root cause of the issue and is actively working to implement a fix. We remain focused on resolving this as quickly as possible and will provide further updates as progress is made. Please contact support@brightlysoftware.com with any questions.
Posted Apr 10, 2026 - 14:36 EDT

Update

We are continuing to investigate an issue where Work Order counts are not displaying correctly on the MaintenanceDirect home page due to a problem with the Work Queue filter. Resolving this remains our top priority, and our team is actively working toward a fix. We will provide another update as soon as more information or a resolution is available.

Until this is resolved, you can change the “Work Queue” drop-down menu to “Blank”, which should allow your data to populate correctly. Thank you for your continued patience. If you have any questions, please contact support@brightlysoftware.com.
Posted Apr 09, 2026 - 16:26 EDT

Investigating

Our team is currently investigating Work Orders counts not displaying correctly on the home page in MaintenanceDirect due to an issue with the Work Queue filter. This issue is impacting the Administrator, Supervisor I, and Supervisor II user roles. We are investigating this as our top priority and will work to have a resolution out as soon as possible. As a work around you can change "Work Queue" drop down menu to "Blank" and your data will populate.

Thank you for your patience! Please contact support@brightlysoftware.com if you have any questions.
Posted Apr 09, 2026 - 09:52 EDT
This incident affects: Work and Asset Management (MaintenanceDirect).