Formerly Dude Solutions
Status Page

The Brightly status page is a real-time, 24/7 health check for all of our products. Our goal is to be transparent, and give our clients reliable information to let you know how we’re doing.

More Info: Online Help  |  Data Security  |  Business Continuity

Possible PM Generation Issue

Incident Report for Brightly Software

Resolved

This issue is now resolved and Planned Maintenance (PM) work orders should now be generated. If there are any issues please contact Support at: assetessentialshelp@brightlysoftware.com
Posted May 19, 2025 - 15:28 EDT

Investigating

Our team is currently investigating an issue where preventive maintenance (PM) work orders may not have run as scheduled this morning in Asset Essentials. Resolving this is a top priority, and we are actively working to identify the root cause and implement a solution. Thank you for your patience.
Posted May 19, 2025 - 09:20 EDT
This incident affected: Work and Asset Management (Asset Essentials).